How to root your m9 the very easy way

6 posts / 0 new
Last post
How to root your m9 the very easy way

hello Pipo m9 users. I just wanna Share the link on how to easily have root access on your pipo m9.
it's very easy and convenient.., all you have to do is 1.) follow instruction VERY CAREFUL 2.) click and WAIT PATIENTLY

[direct link 1]
[direct link 2]

PS. *QQ Phone manager is in Chinese, i didn't understand it either ^_^.
*don't know if it works for other pipo devices but "i think" it works for all rk3188 ( not really sure).
*this is good for INSTALLING DRIVERS if you cant install it or if it doesn't automatically install. QQ phone manager will automatically FIND and INSTALL the drivers for you

all credits to Dick Chan/

Jancis's picture
Thanks, luckyko7

Many thanks for this, luckyko7. I'm a bit concerned about this "QQ Phone manager" that might contain anything, but since it is for windows, i don't care too much :)

New Firmware Installation?

The USB port on my Pipo M9 pro is not working. Is there a way to install new firmware by copying the *.img file to root? Once copied, what do I do next?

Jancis's picture
I have not tried setting up

I have not tried setting up CWM (ClockWork Mod) loader, but I think you could flash images from SD card using that. I believe somewhere was version for pipo m9.

Why usb wouldn't work, is it driver issue or wrong USB port maybe? Did you set "Debugging mode" for USB port?

try one of these tutorials, for windows:

or linux:

Conny Landstedt
Conny Landstedt's picture
The USB port on the device

The USB port on the device requires an extra long usb connector on the cable, I used a knife and removed 1mm of plastic so I could get my cable to connect to the Pipos USB port.

Hope this solves your issue with the USB port.

Jancis's picture
Good idea, thanks for taking

Good idea, thanks for taking a bit different approach to this issue! Just to point out, I think Conny meant removing plastic from USB cable, not the tablet. I've done similar thing for another device when metal part of USB connector turned out to be too short for it, and it indeed works.